[Thread Prev][Thread Next][Index]

Re: FFTA encountered missing data a ...

Hi Ansley,

Ansley Manke wrote:

Hi Antonio,
The FFT functions work on  time series having no missing
data. The error message indicates that the first time step of the
data you're sending to the function has missing data.  You might
try listing the first few times of  variable_mean[l=1:428] to
see what's happening, or look at what is in the variable with
the command

yes? STAT variable_mean[l=1:428]

You are rigth I have 1 value flagged as bad data at this location: (i,j,k,l) -111 -111 -111 1

How do I can overcome this problem? Maybe replacing the bad value with the mean? but how?

Thanks in advance



Ansley Manke

arv@ono.com wrote:


I've tried to perform the following FFTA analysis but I get this
result.Don't know where is my mistake

Thanks in advance.

Antonio Rodriguez

use wind.nc
DEF AXIS/T=16-JAN-1967:17-AUG-2002:1/UNITS=months regt
*** NOTE: /UNIT=MONTHS is ambiguous ... using 1/12 of 365.2425 days
DEF AXIS/X=10W:6W:1 x10
DEF AXIS/y=34n:38n:1 y10
DEFINE GRID/x=x10/y=y10 g10x10
SET GRID g10x10
LET regular_variable = UV_MAG_MEAN[GT=regt]
LET variable_mean = regular_variable[x=10w:6w@ave,y=34n:38n@ave]
LET FFT_variable = FFTA(variable_mean[l=1:428])
PLOT FFT_variable
*** NOTE: CYC/MONTHS                               is ambiguous ...
using 1/12 of 365 days.

Bailing out of external function "ffta":
       FFTA encountered missing data at (i,j,k,l) -111 -111 -111    1
**ERROR: : error in external function

Ansley Manke  Pacific Marine Environmental Laboratory  Seattle WA  (206)526-6246

[Thread Prev][Thread Next][Index]

Dept of Commerce / NOAA / OAR / PMEL / TMAP

Contact Us | Privacy Policy | Disclaimer | Accessibility Statement